Probleem
Revit 2024
Revit start niet op en geeft de volgende melding:
De journal file ziet er ongeveer zo uit:
DBG_WARN: Failed to launch Worker: line 203 of E:\Ship\2024_px64\Source\Revit\RevitDB\Managers\MultiProcessImpl.cpp.
Failed to create worker 1
Revit 2023 en eerder
Revit start niet op en geeft de volgende melding:
De journal file ziet er ongeveer zo uit:
' 1:< DBG_WARN: failed to create message_queue named 'Session1764_P0MasterQueue' because boost::interprocess::intermodule_singleton initialization failed: line 202 of NOBLE\ManageWorkerServices.cpp.
' 1:< DBG_WARN: Could not establish Worker Services!: line 140 of NOBLE\ManageWorkerServices.cpp.
'C DD-MMM-YYYY HH:MM:SS.SSS; 1:< logging finished virtualization services
'C DD-MMM-YYYY HH:MM:SS.SSS; 1:< logging finished worker services
'C DD-MMM-YYYY HH:MM:SS.SSS; 1:< logging erased queues
' 0:< TaskDialog "RevitWorker.exe was not found."
Oorzaak
- Cybereason blokkeert het RevitWorker proces
- RevitWorker.exe wordt automatisch opgestart als administrator
- Windows problemen
- Missende Windows Updates
- Corrupte Windows updates
- Rechten
- Corrupte Windows Management Instrumentation Service (WMI)
Oplossing
Cybereason
Schakel het programma Cybereason tijdelijk uit.
Indien dit het probleem verholpen heeft, ga dan na of er updates beschikbaar zijn voor het programma en/of neem contact op met de support van Cybereason om ervoor te zorgen dat het programma het RevitWorker proces niet onderbreekt.
RevitWorker.exe opstarten als administrator
Wanneer het RevitWorker.exe bestand wordt opgestart als administrator en Revit wordt dit niet, kan dit voor problemen zorgen. Revit kan dan namelijk niet goed communiceren met het RevitWorker.exe bestand.
Test of dit inderdaad de oorzaak is d.m.v. het volgen van de volgende stappen:
- Klik met de rechtermuisknop op het Revit icoon (vanaf je Desktop of het WIndows Startmenu)
- Selecteer uitvoeren als administrator
Indien dit het probleem heeft opgelost, betekent het dat het RevitWorker.exe bestand ook als administrator wordt geopend.
Volg de volgende stappen om het probleem op te lossen:
- Navigeer naar de Revit installatie map (standaard is deze te vinden onder C:\Program Files\Autodesk\Revit ####)
- Klik met de rechtermuisknop op het RevitWorkers.exe bestand en selecteer 'Eigenschappen'
- Navigeer naar het tabblad 'Compatibiliteit'
- Vink onderstaande vinkjes uit
- Klik op 'Toepassen' en daarna op 'OK'
- Start Revit nu normaal op (dus niet als administrator)
Windows problemen
System Information "Can't Collect Information"
Volg de volgende stappen om na te gaan of dit de oorzaak is van het probleem:
- Klik op WIndows Start
- Typ het volgende in: msinfo32.exe
- Klik op ENTER, er opent nu een applicatie
- Ga na of de volgende foutmelding verschijnt:
Indien bovenstaande foutmelding verschijnt, betekent het dat de Windows Management Instrumentation service niet naar behoren werkt. Volg de volgende stappen om dit op te lossen:
- Klik op Windows Start
- Typ het volgende in: services
- Navigeer in de lijst naar de Windows Managegment Instrumentation
- Klik hierop met rechtermuisknop en selecteer daarna 'stoppen'
- Open Kladblok
- Plak hier de volgende tekst in:
@echo on cd /d c:\temp if not exist %windir%\system32\wbem goto TryInstall cd /d %windir%\system32\wbem net stop winmgmt winmgmt /kill if exist Rep_bak rd Rep_bak /s /q rename Repository Rep_bak for %%i in (*.dll) do RegSvr32 -s %%i for %%i in (*.exe) do call :FixSrv %%i for %%i in (*.mof,*.mfl) do Mofcomp %%i net start winmgmt goto End :FixSrv if /I (%1) == (wbemcntl.exe) goto SkipSrv if /I (%1) == (wbemtest.exe) goto SkipSrv if /I (%1) == (mofcomp.exe) goto SkipSrv %1 /Regserver :SkipSrv goto End :TryInstall if not exist wmicore.exe goto End wmicore /s net start winmgmt :End
- Sla het bestand op als WBEM_Fix.bat in de volgende map: C:\Autodesk
- Klik met de rechtermuisknop op het bestand en selecteer 'uitvoeren als administrator
- De opdrachtprompt zal nu in beeld verschijnen en een aantal stappen uitvoeren, wacht tot deze zichzelf afgesloten heeft
- Start Revit opnieuw op
Missende en corrupte Windows Updates
- Ga naar Windows Start
- Typ het volgende in: Controleren op updates
- Voer alle updates uit en start de computer opnieuw op indien nodig
Heeft dit het probleem niet opgelost? Volg dan de volgende stappen volgens de Support van Microsoft.
Problemen met rechten
Los onderstaande probleem op met de IT beheerder van jouw bedrijf.
"Users" / "Gebruikers" dienen de volledige rechten en toegang te hebben tot de volgende map:
- C:\Users\Public\Public Documents\Autodesk
"Users" / "Gebruikers" dienen de volledige rechten en toegang te hebben tot de registry key:
- KEY_LOCAL_MACHINE\SOFTWARE\Autodesk
Zie ook het originele artikel van Autodesk d.d. 02/02/24 met vergelijkbare foutmeldingen
Zie ook het originele artikel van Autodesk d.d. 01/02/24